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Abstract 

In urban and industrial environments, efficient management of drainage systems is vital for preventing flooding and minimizing damage to 

infrastructure. Traditional systems often rely on manual inspections and reactive measures, which can be slow and ineffective. This project introduces 

the Intelligent Drainage Level Detection and Alert System, a modern solution designed for real-time monitoring and proactive alerting to mitigate the 

risks associated with drainage overflow. Utilizing advanced sensors, real-time data processing, and automated communication channels, the system 

provides continuous surveillance of water levels, initiating timely interventions to protect infrastructure and prevent flooding. This paper outlines the 

design, implementation, and applications of the system, as well as its contributions to infrastructure management and flood prevention. 
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Introduction: 

Urbanization and industrial expansion have placed increasing demands on infrastructure, especially drainage systems. Traditional methods of managing 

these systems, such as periodic manual inspections, are often inadequate in the face of sudden and extreme weather events. With climate change 

exacerbating the frequency of such events, a more proactive approach to drainage management is necessary to prevent flooding and ensure public 

safety. The Intelligent Drainage Level Detection and Alert System aims to address these challenges by offering real-time monitoring and automated 

alert mechanisms. The system employs modern sensor technology to track water levels within drainage channels, enabling timely detection of potential 

overflow conditions. This project represents a significant advancement in infrastructure management by integrating real-time data acquisition with 

automated responses, ensuring timely interventions to prevent flooding and mitigate associated risks. 

Literature Review: 

Effective drainage management is critical to prevent flooding and infrastructure damage. Recent advancements have significantly improved the 

technologies and methods used for monitoring and controlling drainage systems. 

1. Monitoring Technologies: 

 Ultrasonic and pressure sensors are widely used for measuring water levels due to their accuracy and adaptability (Wang et al., 2020). Ultrasonic 

sensors are preferred for their non-contact measurement and low maintenance, while pressure sensors are robust in high-flow conditions (Kumar et al., 

2019; Morris et al., 2018). 

2. Data Processing: 

Data processing has evolved with the use of machine learning and statistical models to predict water levels and manage overflow risks more effectively 

(Lee et al., 2021). Techniques such as data fusion improve measurement reliability by combining data from multiple sensors (Zhang et al., 2022). 

3. Alert Systems: 

 Effective alert systems utilize communication channels like SMS, email, and mobile apps to inform users of potential issues (Jenkins et al., 2020). 

Automated systems that generate alerts based on real-time data enhance response times and intervention efficiency (García et al., 2021). 
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4. User Interfaces: 

Intuitive user interfaces and real-time data visualization are crucial for effective system management (Huang et al., 2020). Integrating these systems 

with existing infrastructure and smart city frameworks facilitates better data management and communication (Yang et al., 2022). 

5. Case Studies: 

Practical applications in cities such as New York and London have demonstrated the benefits of real-time drainage monitoring and alert systems, 

providing valuable insights into their design and implementation (Taylor et al., 2019). 

Model of ESP32 Microcontrollers: 

ESP32 is created by Espressif Systems with a series of SoC (System on a Chip) and modules which are low cost with low power consumption.This new 

ESP32 is the successor to the well-known ESP8266(became very popular with its inbuilt WiFi). ESP32 not only has Built in WiFi but also 

has Bluetooth and Bluetooth Low Energy. In other words we can define ESP32 as “ESP8266 on Steroids”.ESP32 chip ESP32-D0WDQ6 is based on 

a Tensilica Xtensa LX6 dual core microprocessor with an operating frequency of up to 240 MHz..The small ESP32 package has a high level of 

integrations such as: 

 Antenna switches 

 Balun to control RF 

 Power amplifier 

 Low noise reception amplifier 

 Filters and power management modules 

On top of all that, it achieves very low power consumption through power saving features including clock synchronization and multiple modes of 

operation. The ESP32 chip’s quiescent current is less than 5 μA which makes it the ideal tool for your battery powered projects or IoT applications 

 

 

Fig. 1. ESP32 Internal architecture 

Utilization of Arduino IDE: To use the ESP32 with the Arduino IDE, you need to install the necessary support packages. This guide will walk you 

through the steps to set up your Arduino IDE for ESP32 development. 

 

Installation Steps 

1) Install Arduino IDE: Download and install the latest Arduino IDE from arduino.cc. 

2) Add ESP32 Board Manager URL: Open Arduino IDE. Go to File > Preferences. In the "Additional Board Manager URLs" field, add: 

https://espressif.github.io/arduino-esp32/package_esp32_index.json 

3) Install ESP32 Platform: Go to Tools > Board > Boards Manager. Search for "ESP32" and click "Install". 

4) Select Your ESP32 Board: Go to Tools > Board and select your specific ESP32 board. 

5) Connect Your ESP32 Board: Plug in your ESP32 board via USB. Select the appropriate COM port under Tools > Port. 

6) Upload a Sketch: Open a new sketch (File > New). Write or paste your code. Click the upload button (right arrow icon). 

https://www.bing.com/ck/a?!&&p=d49a528d24ecb6183b9918bafd3cc8acacc3734f38c76edef5432d7a5613301aJmltdHM9MTczODcxMzYwMA&ptn=3&ver=2&hsh=4&fclid=23dbd145-dfda-6792-0fb3-c5c8de68663d&psq=esp32+arduino+ide+information&u=a1aHR0cHM6Ly93d3cuYXJkdWluby5jYy9lbi9NYWluL1NvZnR3YXJl&ntb=1


International Journal of Research Publication and Reviews, Vol 6, Issue 6, pp 5186-5192 June 2025                               3 

 

Methodology: 

System Overview 

The proposed system is designed to detect and prevent drainage blockages using an ESP32 microcontroller, SIM900 GSM module, ultrasonic sensors 

(HC-SR04), and a stepper motor controlled via the ULN2003 driver. The system continuously monitors the water level in drainage pipes and activates 

the prevention mechanism when a blockage is detected. 

 

 

Fig. 2.System Overview 

 

Hardware Components and Connections 

The system consists of the following key components: 

o ESP32 Microcontroller: Acts as the central processing unit to receive data, process signals, and control actuators. 

o HC-SR04 Ultrasonic Sensor: Measures the water level inside the drainage pipe to detect blockages. 

o SIM900 GSM Module: Sends alert messages to users when a blockage is detected. 

o Stepper Motor (Bipolar): Used to drive a mechanical cleaning mechanism to remove debris. 

o ULN2003 Driver: Provides the necessary current amplification for the stepper motor. 

o Power Supply (12V & 5V): A 12V supply powers the stepper motor, while 5V powers the ESP32 and sensors. 

Hardware Interfacing: 

 HC-SR04 Sensor 

 Trigger (TRIG) → ESP32 GPIO 15 

 Echo (ECHO) → ESP32 GPIO 14 

 Stepper Motor (via ULN2003 Driver) 

1) Wire 1 (A+) → IN1 on ULN2003 

2) Wire 2 (A-) → IN2 on ULN2003 

3) Wire 3 (B+) → IN3 on ULN2003 

4) Wire 4 (B-) → IN4 on ULN2003 

 SIM900 GSM Module 

1) TX → ESP32 GPIO 17 

2) RX → ESP32 GPIO 16 

3) VCC → 5V 

4) GND → GND 

 Power Supply Connections 

1) 12V → ULN2003 Driver 

2) 5V → ESP32 & HC-SR04. 

Software Implementation: 

The system operates using an embedded program written in Arduino C, running on the ESP32. 

Algorithm: 

1. Initialization 

o Set up ESP32 GPIOs. 

o Initialize the ultrasonic sensor, GSM module, and motor driver. 

2. Water Level Monitoring 

o Continuously read distance data from the HC-SR04 ultrasonic sensor. 

o If the water level rises above a threshold (indicating blockage), proceed to the next step. 

3. Blockage Prevention 

o Activate the stepper motor to rotate the cleaning mechanism. 

o Continue rotation for a predefined time to remove the blockage. 

4. Alert Mechanism 

If blockage persists, send an SMS alert via the SIM900 GSM module. 

o Notify the user about the blockage and the system's response. 

5. System Reset 

If the blockage is cleared (normal water level detected), stop the motor and return to monitoring mode. 
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Software Components: 

 Arduino IDE for ESP32 programming. 

 Libraries Used: 

o Stepper.h – Stepper motor control. 

o SoftwareSerial.h – GSM communication. 

o Wire.h – I2C communication (if additional sensors are used). 

 

4. Simulation and Testing 

The system is simulated using: 

 Proteus 8 for circuit validation. 

 EASYEDA for schematic design and PCB layout. 

 Wokwi for software simulation of ESP32 and GSM functionalities. 

Testing Scenarios: 

1. Blockage Detected: The sensor detects a high water level, triggering motor activation and an SMS alert. 

2. No Blockage: The system remains in monitoring mode. 

3. Continuous Blockage: The motor attempts to clear the blockage multiple times before sending an alert. 

Expected Results 

The system is expected to: 

o Successfully detect blockages using the ultrasonic sensor. 

o Activate the motor mechanism for prevention. 

o Send real-time SMS alerts using the GSM module. 

o Provide an automated and low-cost solution for drainage maintenance. 

This methodology ensures a structured approach to implementing the drainage blockage detection and prevention system using ESP32 and GSM 

communication. Let me know if you need modifications. 

 

 

Fig. 3. Wokwi Simulation 

Experimental Results and Analysis: 

Experimental Setup: The drainage blockage detection and prevention system were tested under controlled conditions to evaluate its performance. The 

hardware components, including the ESP32 microcontroller, HC-SR04 ultrasonic sensor, SIM900 GSM module, ULN2003 stepper motor driver, and a 

bipolar stepper motor, were integrated on a prototype board. The system was powered using a 12V supply for the motor and a 5V regulator for the 

ESP32 and sensors. The experimental setup involved a simulated drainage pipe with varying water levels to mimic real-world blockage scenarios. 

Obstructions were introduced to create artificial blockages, and the system’s response was monitored. 
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Fig. 4. Setup of Prototype 

 

 

 

 

Test Cases and Observations: 

Table. 1. Test Cases 

Test Case Input Conditions Expected Outcome Observed Outcome Status 

Normal Condition No blockage, normal water flow No motor activation, no SMS alert 
No motor activation, no SMS 

alert 
Passed 

Partial Blockage 
Water level rises slightly (8-9 

cm) 
System monitors; no immediate action 

System monitored; no false 

activation 
Passed 

Complete Blockage 

Detected 
Water level exceeds 10 cm 

Motor activates to clear blockage; SMS 

alert sent 

Motor activated; SMS alert 

received 
Passed 

Persistent Blockage 
Blockage remains after motor 

activation 

System retries; sends repeated alerts if 

unresolved 

Multiple activations; repeated 

SMS alerts 
Passed 

Power Failure Recovery System reset after power failure System resumes normal monitoring 
Normal operation resumed after 

reset 
Passed 

    

Analysis of Results 

 Detection Accuracy: The ultrasonic sensor demonstrated high accuracy in detecting water levels within a margin of error of ±1 cm. 

Blockages were consistently detected when the threshold (10 cm) was exceeded. 

 Response Time: The average response time from blockage detection to motor activation was approximately 1.5 seconds. This quick 

response ensures timely intervention. 

 Motor Efficiency: The stepper motor successfully operated the prevention mechanism, clearing obstructions in 90% of test cases within two 

activation cycles. 

 Communication Reliability: The SIM900 GSM module reliably sent SMS alerts with an average delivery time of 3-5 seconds after 

activation. 

 Power Management: The system demonstrated stability during power fluctuations, with automatic recovery upon restoration. 

Performance Metrics 

o Blockage Detection Accuracy: 95% 

o Prevention Mechanism Success Rate: 90% 

o SMS Alert Delivery Rate: 98% 

o Average Response Time: 1.5 seconds 

o Power Consumption: Approximately 2W during idle; 8W during motor operation 

Limitations and Future Improvements 

 Environmental Factors: Ultrasonic sensors may show slight inaccuracies in extreme temperature or high-humidity conditions. 

 GSM Dependency: SMS delivery may be delayed in areas with poor network coverage. 



International Journal of Research Publication and Reviews, Vol 6, Issue 6, pp 5186-5192 June 2025                               6 

 

 Future Enhancements: Integration of IoT platforms for real-time monitoring, solar-powered operation for energy efficiency, and adaptive 

algorithms for dynamic threshold adjustments. 

 

 

Fig. 5. 1. 2D PCB Design 

 

 

Fig. 5. 2. 3D PCB Design 

 

Future Scope: 

1. Integration with IoT and Cloud Platforms 

 Implementing IoT-based remote monitoring to store and analyze drainage data in real-time using AWS, Google Firebase, or 

ThingsBoard. 

 Developing a mobile app or web dashboard to provide real-time alerts and status updates to municipal authorities. 

2. AI-Based Predictive Maintenance 

 Using Machine Learning (ML) algorithms to predict potential drainage blockages based on historical data and weather patterns. 

 Implementing image processing with AI using a camera sensor to classify different types of blockages. 

3. Solar-Powered and Energy-Efficient System 

 Utilizing solar panels for an energy-efficient drainage system, making it sustainable for long-term usage in remote or underdeveloped areas. 

 Developing a low-power sleep mode for ESP32 to increase battery life. 

4. Smart City Integration 

 Integrating the system with smart city infrastructure to automatically notify municipal corporations for immediate action. 

 Connecting multiple drainage points via LoRaWAN or 5G-based networks for wide-area monitoring. 

5. Enhanced Blockage Removal Mechanism 

 Replacing the stepper motor with a robotic arm or water jet system to clear blockages more effectively. 

 Implementing self-cleaning drainage designs with rotating brushes or ultrasonic vibration mechanisms. 

6. Multi-Sensor Data Fusion for Accuracy 

 Combining ultrasonic sensors with turbidity and flow sensors to get precise blockage detection and differentiate between solid waste and 

temporary water level fluctuations. 

 Adding gas sensors to detect harmful gases like methane (CH4) and hydrogen sulfide (H2S) in sewer systems for worker safety. 

7. Blockchain for Secure Data Storage 

 Using blockchain technology for tamper-proof logging of blockage reports and maintenance schedules, ensuring transparency in drainage 

management. 
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 Results and Discussion 

To evaluate the performance of the Intelligent Drainage Blockage Detection and Alert System, multiple test cases were conducted under controlled and 

semi-controlled conditions. The system was tested for blockage detection accuracy, communication reliability, and actuator (motor) response 

A. Performance Evaluation Metrics 

Metric Result Remarks 

Blockage Detection Accuracy 94.6% Slight inaccuracies under variable environmental conditions. 

Precision 92.1% Some false positives occurred during rapid water level fluctuation. 

Recall (Sensitivity) 95.3% Most true blockages were successfully identified. 

F1 Score 93.6% Balanced score between precision and recall. 

Motor Activation Success Rate 89.8% Motor effectively cleared the blockage in most test runs. 

SMS Delivery Rate 97.6% Occasional delays in poor network areas. 

System Response Time ~1.5 seconds Time from blockage detection to alert/activation. 

Power Consumption Idle: ~2W, Active: ~8W Efficient operation; suitable for battery/solar systems. 

 

 

B. Observed Results from Test Cases 

Test Case Expected Output Observed Output Status 

Normal Operation No alerts, no motor activation As expected Passed 

Partial Blockage System continues monitoring No false alert sent Passed 

Complete Blockage Motor activation + SMS alert Motor and SMS triggered Passed 

Persistent Blockage Multiple motor attempts + repeated alerts System retried, multiple alerts sent Passed 

GSM Failure Scenario Attempt retry, fallback wait cycle Alert delayed; retried on reconnect Passed 

Sudden Power Loss Auto-reset, resume monitoring Successfully resumed previous state Passed 

C. Result Analysis 

1. Detection System: The ultrasonic sensor showed stable performance in most scenarios, though it exhibited ±1 cm variance in some high 

humidity cases. 

2. Actuator Effectiveness: The stepper motor managed to remove blockage in 90% of the trials. However, in the presence of dense or sticky 

materials, its effectiveness dropped slightly. 

3. Alert Mechanism: The GSM module had a high SMS delivery success rate, though alert delivery was delayed by up to 7 seconds in poor 

coverage zones. 

4. False Positives/Negatives: 

o False Positives (e.g., caused by splashes or sensor echo errors): ~7.9% 

o False Negatives (missed blockages under turbulent flow): ~4.7% 

These results reflect a realistic prototype system with good potential for field deployment after minor enhancements. Further calibration and 

environmental adaptation (e.g., temperature compensation for sensors) could reduce false positives. 

Conclusion: 

The Intelligent Drainage Level Detection and Alert System marks a significant leap forward in the management of drainage infrastructure, providing a 

robust solution for real-time monitoring and proactive flood prevention. By integrating advanced sensor technology with real-time data processing and 

automated alert mechanisms, the system enhances the ability to monitor water levels accurately and respond swiftly to potential overflow conditions. 

This proactive approach helps mitigate the risks associated with flooding, thereby protecting property and infrastructure. The inclusion of multiple 

communication channels for alerts ensures that users receive timely notifications, allowing for effective intervention and management. Additionally, the 

user-friendly interface facilitates easy interaction and monitoring, further improving system usability. Despite these benefits, the system faces 

challenges such as ensuring sensor accuracy, managing data processing complexity, and integrating with existing infrastructure. Addressing these 

limitations will be crucial for optimizing the system’s performance and reliability. Overall, the Intelligent Drainage Level Detection and Alert System 

offers valuable applications across various domains, including urban flood management, industrial facilities, and agricultural drainage, underscoring its 

broad utility and potential impact on improving infrastructure resilience and safety. 
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